<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Rain is a soggy pain in the&#8230; &#8211; Blue Ridge Muse</title>
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Blue Ridge Muse &raquo; Feed" href="https://blueridgemuse.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Blue Ridge Muse &raquo; Comments Feed" href="https://blueridgemuse.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Blue Ridge Muse &raquo; Rain is a soggy pain in the&#8230; Comments Feed" href="https://blueridgemuse.com/node/56153/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blueridgemuse.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='gt3pg-pro-blocks-frontend-css'  href='https://blueridgemuse.com/wp-content/plugins/gt3-photo-video-gallery-pro/dist/css/gutenberg/frontend.css?ver=1592333400' type='text/css' media='all' />
<link rel='stylesheet' id='bdt-uikit-css'  href='https://blueridgemuse.com/wp-content/plugins/bdthemes-element-pack/assets/css/bdt-uikit.css?ver=3.2' type='text/css' media='all' />
<link rel='stylesheet' id='element-pack-site-css'  href='https://blueridgemuse.com/wp-content/plugins/bdthemes-element-pack/assets/css/element-pack-site.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://blueridgemuse.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='awesome-weather-css'  href='https://blueridgemuse.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=5.4.2' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif; font-weight: 400; font-size: 14px; line-height: 14px; }
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='location-weather-pro-icons-css'  href='https://blueridgemuse.com/wp-content/plugins/location-weather-pro/assets/css/sp-icons.css?ver=1.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='lwpro-custom-css'  href='https://blueridgemuse.com/wp-content/plugins/location-weather-pro/assets/css/custom.css?ver=1.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='location-weather-pro-style-css'  href='https://blueridgemuse.com/wp-content/plugins/location-weather-pro/assets/css/style.css?ver=1.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='lw-custom-css'  href='https://blueridgemuse.com/wp-content/plugins/location-weather/assets/css/custom.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='location-weather-style-css'  href='https://blueridgemuse.com/wp-content/plugins/location-weather/assets/css/style.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-grid-css'  href='https://blueridgemuse.com/wp-content/themes/generatepress/css/unsemantic-grid.min.css?ver=2.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='https://blueridgemuse.com/wp-content/themes/generatepress/style.min.css?ver=2.4.2' type='text/css' media='all' />
<style id='generate-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='generate-mobile-style-css'  href='https://blueridgemuse.com/wp-content/themes/generatepress/css/mobile.min.css?ver=2.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-icons-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/eicons/css/elementor-icons.min.css?ver=5.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-animations-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/animations/animations.min.css?ver=2.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-frontend-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor/assets/css/frontend.min.css?ver=2.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-pro-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor-pro/assets/css/frontend.min.css?ver=2.10.2' type='text/css' media='all' />
<link rel='stylesheet' id='eihe-front-style-css'  href='https://blueridgemuse.com/wp-content/plugins/emage-hover-effects-for-elementor/assets/css/style.min.css?ver=4.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='eihe-google-font-css'  href='https://fonts.googleapis.com/css?family=Mandali&#038;ver=4.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jet-blog-css'  href='https://blueridgemuse.com/wp-content/plugins/jet-blog/assets/css/jet-blog.css?ver=2.2.8' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-5-all-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/all.min.css?ver=2.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-4-shim-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/v4-shims.min.css?ver=2.9.12' type='text/css' media='all' />
<link rel='stylesheet' id='she-header-style-css'  href='https://blueridgemuse.com/wp-content/plugins/sticky-header-effects-for-elementor/assets/css/she-header-style.css?ver=1.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-global-css'  href='https://blueridgemuse.com/wp-content/uploads/elementor/css/global.css?ver=1592356363' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-post-49310-css'  href='https://blueridgemuse.com/wp-content/uploads/elementor/css/post-49310.css?ver=1592356363' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-post-49453-css'  href='https://blueridgemuse.com/wp-content/uploads/elementor/css/post-49453.css?ver=1592356370' type='text/css' media='all' />
<link rel='stylesheet' id='generate-secondary-nav-css'  href='https://blueridgemuse.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style.min.css?ver=1.10.0' type='text/css' media='all' />
<style id='generate-secondary-nav-inline-css' type='text/css'>
.secondary-navigation{background-color:#636363;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle{color:#ffffff;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:21px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;}.secondary-navigation .main-nav ul li:hover > a,.secondary-navigation .main-nav ul li:focus > a,.secondary-navigation .main-nav ul li.sfHover > a{color:#ffffff;background-color:#303030;}.secondary-navigation .main-nav ul ul li:hover > a,.secondary-navigation .main-nav ul ul li:focus > a,.secondary-navigation .main-nav ul ul li.sfHover > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a, .secondary-navigation .main-nav ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul li[class*="current-menu-"].sfHover > a{color:#222222;background-color:#ffffff;}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a,.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:#474747;}
</style>
<link rel='stylesheet' id='generate-secondary-nav-mobile-css'  href='https://blueridgemuse.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/mobile.min.css?ver=1.10.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://blueridgemuse.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=8.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-1-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic%7CRoboto+Slab%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&#038;ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://blueridgemuse.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/font-awesome/js/v4-shims.min.js?ver=2.9.12'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/sticky-header-effects-for-elementor/assets/js/she-header.js?ver=1.3.2'></script>
<link rel='https://api.w.org/' href='https://blueridgemuse.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blueridgemuse.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blueridgemuse.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Ugly face of racism in Shenandoah County, Va.' href='https://blueridgemuse.com/node/56147' />
<meta name="generator" content="WordPress 5.4.2" />
<link rel="canonical" href="https://blueridgemuse.com/node/56153" />
<link rel='shortlink' href='https://wp.me/pPQfQ-eBH' />
<link rel="alternate" type="application/json+oembed" href="https://blueridgemuse.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblueridgemuse.com%2Fnode%2F56153" />
<link rel="alternate" type="text/xml+oembed" href="https://blueridgemuse.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblueridgemuse.com%2Fnode%2F56153&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.9.0" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel="pingback" href="https://blueridgemuse.com/xmlrpc.php">
<meta name="viewport" content="width=device-width, initial-scale=1"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-4675981680560151",
enable_page_level_ads: true,
tag_partner: "site_kit"
});
</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Rain is a soggy pain in the&#8230;" />
<meta property="og:url" content="https://blueridgemuse.com/node/56153" />
<meta property="og:description" content="&#8230;butt. Thunderstorms are forecast for just about every day left in this already-soaked month and are expected to continue into July." />
<meta property="article:published_time" content="2020-06-18T13:03:41+00:00" />
<meta property="article:modified_time" content="2020-06-18T13:03:45+00:00" />
<meta property="og:site_name" content="Blue Ridge Muse" />
<meta property="og:image" content="https://i0.wp.com/blueridgemuse.com/wp-content/uploads/2015/05/052815rainout-2.jpg?fit=950%2C432&amp;ssl=1" />
<meta property="og:image:width" content="950" />
<meta property="og:image:height" content="432" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@dougthompson" />
<meta name="twitter:text:title" content="Rain is a soggy pain in the&#8230;" />
<meta name="twitter:image" content="https://i0.wp.com/blueridgemuse.com/wp-content/uploads/2015/05/052815rainout-2.jpg?fit=950%2C432&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
			<style type="text/css" id="wp-custom-css">
				.wp-caption .wp-caption-text {
    
    color: #393939;
    font-family: Helvetica;
    font-size: 13px;
    font-weight: 700;
	  text-align: left;
}

/* Quotations */

blockquote {
	font-family: Helvetica;
	font-size: 18px;
	font-style: italic;
	margin: 0.25em 0;
	padding: 0.25em 40px;
	line-height: 1.45;
	position: relative;
}

blockquote:before {
	display: block;
	content: "\201C";
	font-size: 80px;
	position: absolute;
	left: -10px;
	top: -10px;
}

blockquote cite {
	font-size: 14px;
	display: block;
	margin-top: 5px;
}
 
blockquote cite:before {
	content: "\2014 \2009";
}
body { color: #000; }
a { color: #000; }
a:hover { color: #F00; }

section { color: #000; }
a { color: #000; }
a:hover { color: #F00; }
.wp-caption-text {
       line-height: 1.25;
}
.elementor-post__excerpt p:after {
content: " ...";
}
figcaption {
    font-family: "Helvetica", sans-serif;
    font-size: 15px;
    color: #000;
}
.entry-meta {
    font-weight: 600;
}			</style>
		</head>

<body 
	  class="post-template-default single single-post postid-56153 single-format-standard wp-embed-responsive secondary-nav-above-header secondary-nav-aligned-right sticky-menu-fade right-sidebar nav-below-header fluid-header separate-containers active-footer-widgets-0 nav-aligned-left header-aligned-left dropdown-hover featured-image-active elementor-default elementor-template-full-width elementor-kit-53967 elementor-page-51046 elementor-page-50173 elementor-page-49453 full-width-content" itemtype="https://schema.org/Blog" itemscope>
	<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>			<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="secondary-navigation" class="secondary-navigation">
				<div class="inside-navigation grid-container grid-parent">
										<button class="menu-toggle secondary-menu-toggle">
												<span class="mobile-menu">Menu</span>
					</button>
									</div><!-- .inside-navigation -->
			</nav><!-- #secondary-navigation -->
					<div data-elementor-type="header" data-elementor-id="49310" class="elementor elementor-49310 elementor-location-header" data-elementor-settings="[]">
		<div class="elementor-inner">
			<div class="elementor-section-wrap">
						<section class="elementor-element elementor-element-4ebb152 elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="4ebb152" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}">
							<div class="elementor-background-overlay"></div>
							<div class="elementor-container elementor-column-gap-default">
				<div class="elementor-row">
				<div class="elementor-element elementor-element-c108ae2 elementor-column elementor-col-100 elementor-top-column" data-id="c108ae2" data-element_type="column">
			<div class="elementor-column-wrap  elementor-element-populated">
					<div class="elementor-widget-wrap">
				<div class="elementor-element elementor-element-07fe98f elementor-widget elementor-widget-image" data-id="07fe98f" data-element_type="widget" data-widget_type="image.default">
				<div class="elementor-widget-container">
					<div class="elementor-image">
										<img width="970" height="115" src="https://i2.wp.com/blueridgemuse.com/wp-content/uploads/2012/01/muselogo1.png?fit=970%2C115&amp;ssl=1" class="attachment-full size-full" alt="" srcset="https://i2.wp.com/blueridgemuse.com/wp-content/uploads/2012/01/muselogo1.png?w=970&amp;ssl=1 970w, https://i2.wp.com/blueridgemuse.com/wp-content/uploads/2012/01/muselogo1.png?resize=768%2C91&amp;ssl=1 768w, https://i2.wp.com/blueridgemuse.com/wp-content/uploads/2012/01/muselogo1.png?resize=696%2C83&amp;ssl=1 696w, https://i2.wp.com/blueridgemuse.com/wp-content/uploads/2012/01/muselogo1.png?resize=575%2C68&amp;ssl=1 575w, https://i2.wp.com/blueridgemuse.com/wp-content/uploads/2012/01/muselogo1.png?resize=940%2C111&amp;ssl=1 940w" sizes="(max-width: 970px) 100vw, 970px" />											</div>
				</div>
				</div>
				<div class="elementor-element elementor-element-e4e2476 elementor-nav-menu__align-center elementor-nav-menu__text-align-center elementor-nav-menu--indicator-classic elementor-nav-menu--dropdown-tablet elementor-nav-menu--toggle elementor-nav-menu--burger elementor-widget elementor-widget-nav-menu" data-id="e4e2476" data-element_type="widget" data-settings="{&quot;sticky&quot;:&quot;top&quot;,&quot;layout&quot;:&quot;horizontal&quot;,&quot;toggle&quot;:&quot;burger&quot;,&quot;sticky_on&quot;:[&quot;desktop&quot;,&quot;tablet&quot;,&quot;mobile&quot;],&quot;sticky_offset&quot;:0,&quot;sticky_effects_offset&quot;:0}" data-widget_type="nav-menu.default">
				<div class="elementor-widget-container">
						<nav role="navigation" class="elementor-nav-menu--main elementor-nav-menu__container elementor-nav-menu--layout-horizontal e--pointer-underline e--animation-fade"><ul id="menu-1-e4e2476" class="elementor-nav-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-44514"><a href="https://blueridgemuse.com" class="elementor-item">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52922"><a href="https://blueridgemuse.com/node/category/entertainment-2" class="elementor-item">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22448"><a href="https://blueridgemuse.com/node/category/musings" class="elementor-item">Musings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24103"><a href="https://blueridgemuse.com/node/category/news" class="elementor-item">News</a>
<ul class="sub-menu elementor-nav-menu--dropdown">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54998"><a href="https://blueridgemuse.com/node/category/coronavirus" class="elementor-sub-item">Coronavirus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24104"><a href="https://blueridgemuse.com/node/category/fubar" class="elementor-sub-item">FUBAR</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54997"><a href="https://blueridgemuse.com/node/category/news" class="elementor-sub-item">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22489"><a href="https://blueridgemuse.com/node/category/politics" class="elementor-sub-item">Politics</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22452"><a href="https://blueridgemuse.com/node/category/sports" class="elementor-item">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-22451"><a href="https://blueridgemuse.com/node/category/video" class="elementor-item">Visuals</a>
<ul class="sub-menu elementor-nav-menu--dropdown">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22450"><a href="https://blueridgemuse.com/node/category/photography" class="elementor-sub-item">Photos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24102"><a href="https://blueridgemuse.com/node/category/video" class="elementor-sub-item">Video</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25679"><a href="https://blueridgemuse.com/node/category/motorcycle-musings" class="elementor-item">Motorcycle Musings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51147"><a href="https://blueridgemuse.com/about-blue-ridge-muse-2" class="elementor-item">About</a></li>
</ul></nav>
					<div class="elementor-menu-toggle" role="button" tabindex="0" aria-label="Menu Toggle" aria-expanded="false">
			<i class="eicon-menu-bar" aria-hidden="true"></i>
			<span class="elementor-screen-only">Menu</span>
		</div>
			<nav class="elementor-nav-menu--dropdown elementor-nav-menu__container" role="navigation" aria-hidden="true"><ul id="menu-2-e4e2476" class="elementor-nav-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-44514"><a href="https://blueridgemuse.com" class="elementor-item">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52922"><a href="https://blueridgemuse.com/node/category/entertainment-2" class="elementor-item">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22448"><a href="https://blueridgemuse.com/node/category/musings" class="elementor-item">Musings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24103"><a href="https://blueridgemuse.com/node/category/news" class="elementor-item">News</a>
<ul class="sub-menu elementor-nav-menu--dropdown">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54998"><a href="https://blueridgemuse.com/node/category/coronavirus" class="elementor-sub-item">Coronavirus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24104"><a href="https://blueridgemuse.com/node/category/fubar" class="elementor-sub-item">FUBAR</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54997"><a href="https://blueridgemuse.com/node/category/news" class="elementor-sub-item">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22489"><a href="https://blueridgemuse.com/node/category/politics" class="elementor-sub-item">Politics</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22452"><a href="https://blueridgemuse.com/node/category/sports" class="elementor-item">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-22451"><a href="https://blueridgemuse.com/node/category/video" class="elementor-item">Visuals</a>
<ul class="sub-menu elementor-nav-menu--dropdown">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22450"><a href="https://blueridgemuse.com/node/category/photography" class="elementor-sub-item">Photos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24102"><a href="https://blueridgemuse.com/node/category/video" class="elementor-sub-item">Video</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25679"><a href="https://blueridgemuse.com/node/category/motorcycle-musings" class="elementor-item">Motorcycle Musings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51147"><a href="https://blueridgemuse.com/about-blue-ridge-muse-2" class="elementor-item">About</a></li>
</ul></nav>
				</div>
				</div>
						</div>
			</div>
		</div>
						</div>
			</div>
		</section>
					</div>
		</div>
		</div>
		
	<div id="page" class="hfeed site grid-container container grid-parent">
				<div id="content" class="site-content">
					<div data-elementor-type="single" data-elementor-id="49453" class="elementor elementor-49453 elementor-location-single post-56153 post type-post status-publish format-standard has-post-thumbnail hentry category-weather-2 tag-heavy-rain tag-national-weather-service tag-rain tag-storms tag-thunderstorms tag-weather" data-elementor-settings="[]">
		<div class="elementor-inner">
			<div class="elementor-section-wrap">
						<section class="elementor-element elementor-element-16f993b elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="16f993b" data-element_type="section">
						<div class="elementor-container elementor-column-gap-default">
				<div class="elementor-row">
				<div class="elementor-element elementor-element-b9c2a7a elementor-column elementor-col-100 elementor-top-column" data-id="b9c2a7a" data-element_type="column">
			<div class="elementor-column-wrap  elementor-element-populated">
					<div class="elementor-widget-wrap">
				<div class="elementor-element elementor-element-d57f65d elementor-widget elementor-widget-theme-post-title elementor-page-title elementor-widget-heading" data-id="d57f65d" data-element_type="widget" data-widget_type="theme-post-title.default">
				<div class="elementor-widget-container">
			<h3 class="elementor-heading-title elementor-size-default">Rain is a soggy pain in the&#8230;</h3>		</div>
				</div>
				<div class="elementor-element elementor-element-393f5b7 elementor-widget elementor-widget-post-info" data-id="393f5b7" data-element_type="widget" data-widget_type="post-info.default">
				<div class="elementor-widget-container">
					<ul class="elementor-inline-items elementor-icon-list-items elementor-post-info">
					<li class="elementor-icon-list-item elementor-repeater-item-2f8cf01 elementor-inline-item" itemprop="author">
						<a href="https://blueridgemuse.com/node/author/doug-thompson">
														<span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-author">
							<span class="elementor-post-info__item-prefix">By</span>
										DOUG THOMPSON					</span>
									</a>
				</li>
				<li class="elementor-icon-list-item elementor-repeater-item-b6b2108 elementor-inline-item" itemprop="datePublished">
						<a href="https://blueridgemuse.com/node/date/2020/06/18">
														<span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-date">
										June 18, 2020					</span>
									</a>
				</li>
				<li class="elementor-icon-list-item elementor-repeater-item-95964dd elementor-inline-item">
													<span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-time">
										9:03 am					</span>
								</li>
				<li class="elementor-icon-list-item elementor-repeater-item-339685f elementor-inline-item" itemprop="about">
										<span class="elementor-icon-list-icon">
								<i aria-hidden="true" class="fas fa-tags"></i>							</span>
									<span class="elementor-icon-list-text elementor-post-info__item elementor-post-info__item--type-terms">
										<span class="elementor-post-info__terms-list">
				<a href="https://blueridgemuse.com/node/category/weather-2" class="elementor-post-info__terms-list-item">Weather</a>				</span>
					</span>
								</li>
				</ul>
				</div>
				</div>
				<div class="elementor-element elementor-element-ef12264 elementor-widget elementor-widget-theme-post-excerpt" data-id="ef12264" data-element_type="widget" data-widget_type="theme-post-excerpt.default">
				<div class="elementor-widget-container">
			...butt. Thunderstorms are forecast for just about every day left in this already-soaked month and are expected to continue into July.		</div>
				</div>
				<div class="elementor-element elementor-element-66d65ed elementor-widget elementor-widget-theme-post-featured-image elementor-widget-image" data-id="66d65ed" data-element_type="widget" data-widget_type="theme-post-featured-image.default">
				<div class="elementor-widget-container">
					<div class="elementor-image">
							<figure class="wp-caption">
										<img width="950" height="432" src="https://i0.wp.com/blueridgemuse.com/wp-content/uploads/2015/05/052815rainout-2.jpg?fit=950%2C432&amp;ssl=1" class="attachment-full size-full" alt="" srcset="https://i0.wp.com/blueridgemuse.com/wp-content/uploads/2015/05/052815rainout-2.jpg?w=950&amp;ssl=1 950w, https://i0.wp.com/blueridgemuse.com/wp-content/uploads/2015/05/052815rainout-2.jpg?resize=768%2C349&amp;ssl=1 768w, https://i0.wp.com/blueridgemuse.com/wp-content/uploads/2015/05/052815rainout-2.jpg?resize=696%2C316&amp;ssl=1 696w, https://i0.wp.com/blueridgemuse.com/wp-content/uploads/2015/05/052815rainout-2.jpg?resize=924%2C420&amp;ssl=1 924w, https://i0.wp.com/blueridgemuse.com/wp-content/uploads/2015/05/052815rainout-2.jpg?resize=575%2C261&amp;ssl=1 575w, https://i0.wp.com/blueridgemuse.com/wp-content/uploads/2015/05/052815rainout-2.jpg?resize=940%2C427&amp;ssl=1 940w" sizes="(max-width: 950px) 100vw, 950px" />											<figcaption class="widget-image-caption wp-caption-text">Mud, mud and more mud.</figcaption>
										</figure>
					</div>
				</div>
				</div>
					<div data-parallax-id="bdt_scenec38db40" id="bdt_scenec38db40" class="parallax-scene">
								
										
					<div data-depth="0.1" class="bdt-scene-item" style="background-position-x: 50%; background-position-y: 50%; background-size: cover;"></div>
					
							</div>

					<section class="has-bdt-parallax elementor-element elementor-element-c38db40 elementor-section-full_width elementor-section-height-default elementor-section-height-default elementor-section elementor-inner-section" data-id="c38db40" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}">
						<div class="elementor-container elementor-column-gap-default">
				<div class="elementor-row">
				<div class="elementor-element elementor-element-71f3a38 elementor-column elementor-col-50 elementor-inner-column" data-id="71f3a38" data-element_type="column">
			<div class="elementor-column-wrap  elementor-element-populated">
					<div class="elementor-widget-wrap">
				<div class="elementor-element elementor-element-89365ec elementor-widget__width-inherit elementor-widget elementor-widget-theme-post-content" data-id="89365ec" data-element_type="widget" data-widget_type="theme-post-content.default">
				<div class="elementor-widget-container">
			
<p>Rain fell by the buckets Wednesday in Southwestern Virginia, leaving roads flooded, basements leaking and contributed to the gloom of a nation felled by a pandemic, upset with rampant racism and unnerved by a government that doesn&#8217;t work.</p>



<p>A brief respite Thursday morning is forecast to end with more storms rumbling through this afternoon and daily thunderstorms for pretty much of rest of June and into July.</p>



<p>Mother Nature, it seems is pissed and taking no prisoners.</p>



<p>This what the current outlook looks like from the National Weather Service office in Blacksburg:</p>



<figure class="wp-block-image size-large"><img src="https://i1.wp.com/blueridgemuse.com/wp-content/uploads/2020/06/061820forecast.png?resize=676%2C800&#038;ssl=1" alt="" class="wp-image-56154" srcset="https://i1.wp.com/blueridgemuse.com/wp-content/uploads/2020/06/061820forecast.png?resize=676%2C800&amp;ssl=1 676w, https://i1.wp.com/blueridgemuse.com/wp-content/uploads/2020/06/061820forecast.png?resize=575%2C680&amp;ssl=1 575w, https://i1.wp.com/blueridgemuse.com/wp-content/uploads/2020/06/061820forecast.png?w=723&amp;ssl=1 723w" sizes="(max-width: 676px) 100vw, 676px" data-recalc-dims="1" /><figcaption>(Courtesy of the National Weather Service and Weather.com)</figcaption></figure>



<p>Our already-damaged driveway is probably somewhere in Patrick County now. It washed aay in the multiple inches of rain that fell Wednesday and getting it dry enough to plow will be impossible if current forecasts are correct.</p>



<p>The advanced arthritis fueled by too many broken bones over the year makes any movement a struggle with pain for my tired, old body when it rains and it is not just raining, it&#8217;s pouring.</p>



<p>If the forecasts listed above are correct, the probability of rain falls to less than 60 percent on Friday and Saturday of next week and, possibly, again on July 2.</p>



<p>Anybody got working plans for an ark?</p>



<p>How long is a cubit?</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://blueridgemuse.com/node/56153?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-56153" class="share-facebook sd-button share-icon" href="https://blueridgemuse.com/node/56153?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://blueridgemuse.com/node/56153#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-56153" class="share-twitter sd-button share-icon" href="https://blueridgemuse.com/node/56153?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://blueridgemuse.com/node/56153?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-56153" class="share-pinterest sd-button share-icon" href="https://blueridgemuse.com/node/56153?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>		</div>
				</div>
				<div class="elementor-element elementor-element-d8dd2ac elementor-widget elementor-widget-divider" data-id="d8dd2ac" data-element_type="widget" data-widget_type="divider.default">
				<div class="elementor-widget-container">
					<div class="elementor-divider">
			<span class="elementor-divider-separator">
						</span>
		</div>
				</div>
				</div>
				<div class="elementor-element elementor-element-23834de elementor-author-box--link-yes elementor-author-box--layout-image-right elementor-author-box--avatar-yes elementor-author-box--name-yes elementor-author-box--biography-yes elementor-widget elementor-widget-author-box" data-id="23834de" data-element_type="widget" data-widget_type="author-box.default">
				<div class="elementor-widget-container">
					<div class="elementor-author-box">
							<div  class="elementor-author-box__avatar">
					<img src="https://secure.gravatar.com/avatar/ab8a446279393919690b0577964e6b4f?s=300&amp;r=g" alt="DOUG THOMPSON">
				</div>
			
			<div class="elementor-author-box__text">
									<div >
						<h4 class="elementor-author-box__name">DOUG THOMPSON</h4>					</div>
				
									<div class="elementor-author-box__bio">
						Long-time newspaperman, photographer, and videographer who sold his first news photo 60 years ago, still writes and shoots photos for Lee Enterprises newspapers, provides TV news for local stations/networks, and produces documentaries. He is also the founder and still publisher of Capitol Hill Blue, the oldest political news channel on the Internet, and owns Blue Ridge Muse, a hyperlocal website in the Blue Ridge Mountains of Southwestern Virginia. A member of the National Press Photographers Association, Thompson also owns Blue Ridge Photography, LLC.					</div>
				
									<a class="elementor-author-box__button elementor-button elementor-size-xs" href="https://blueridgemuse.com/node/author/doug-thompson">
						All Articles					</a>
							</div>
		</div>
				</div>
				</div>
				<div class="elementor-element elementor-element-5b6b176 elementor-widget elementor-widget-post-comments" data-id="5b6b176" data-element_type="widget" data-widget_type="post-comments.theme_comments">
				<div class="elementor-widget-container">
			<div id="comments">

	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/node/56153#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=12355598&#038;postid=56153&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=gravatar_default&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.6.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=d24518948f09a4d12d731a7b5676bf239c700bea#parent=https%3A%2F%2Fblueridgemuse.com%2Fnode%2F56153" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->
		</div>
				</div>
						</div>
			</div>
		</div>
				<div class="elementor-element elementor-element-4e6968a elementor-column elementor-col-50 elementor-inner-column" data-id="4e6968a" data-element_type="column">
			<div class="elementor-column-wrap  elementor-element-populated">
					<div class="elementor-widget-wrap">
				<div class="elementor-element elementor-element-e37e1f4 elementor-share-buttons--view-icon elementor-share-buttons--shape-circle elementor-share-buttons--skin-gradient elementor-grid-0 elementor-share-buttons--color-official elementor-widget elementor-widget-share-buttons" data-id="e37e1f4" data-element_type="widget" data-widget_type="share-buttons.default">
				<div class="elementor-widget-container">
					<div class="elementor-grid">
							<div class="elementor-grid-item">
					<div class="elementor-share-btn elementor-share-btn_facebook">
													<span class="elementor-share-btn__icon">
								<i class="fab fa-facebook" aria-hidden="true"></i>
								<span class="elementor-screen-only">Share on facebook</span>
							</span>
																	</div>
				</div>
								<div class="elementor-grid-item">
					<div class="elementor-share-btn elementor-share-btn_twitter">
													<span class="elementor-share-btn__icon">
								<i class="fab fa-twitter" aria-hidden="true"></i>
								<span class="elementor-screen-only">Share on twitter</span>
							</span>
																	</div>
				</div>
						</div>
				</div>
				</div>
				<div class="elementor-element elementor-element-aa35349 elementor-widget elementor-widget-sidebar" data-id="aa35349" data-element_type="widget" data-widget_type="sidebar.default">
				<div class="elementor-widget-container">
			<aside id="custom_html-17" class="widget_text widget inner-padding widget_custom_html"><h2 class="widget-title">Search the Muse</h2><div class="textwidget custom-html-widget"><style type="text/css">
@import url(//www.google.com/cse/api/branding.css);
</style>
<div class="cse-branding-bottom" style="background-color:#FFFFFF;color:#000000">
  <div class="cse-branding-form">
    <form action="https://www.google.com" id="cse-search-box" target="_blank">
      <div>
        <input type="hidden" name="cx" value="partner-pub-4675981680560151:6522823470" />
        <input type="hidden" name="ie" value="UTF-8" />
        <input type="text" name="q" size="55" />
        <input type="submit" name="sa" value="Search" />
      </div>
    </form>
    <script type="text/javascript" src="https://www.google.com/jsapi"></script>
    <script type="text/javascript">google.load("elements", "1", {packages: "transliteration"});</script>
    <script type="text/javascript" src="https://www.google.com/cse/t13n?form=cse-search-box&t13n_langs=en"></script>
  </div>
  <div class="cse-branding-logo">
    <img src="https://i1.wp.com/www.google.com/images/poweredby_transparent/poweredby_FFFFFF.gif?w=780&#038;ssl=1" alt="Google" data-recalc-dims="1" />
  </div>
  <div class="cse-branding-text">
    Custom Search
  </div>
</div>
</div></aside><aside id="custom_html-19" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 336x280 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-4675981680560151"
     data-ad-slot="6792452309"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="twitter_timeline-10" class="widget inner-padding widget_twitter_timeline"><h2 class="widget-title">Twitter</h2><a class="twitter-timeline" data-height="400" data-theme="light" data-border-color="#e8e8e8" data-lang="EN" data-partner="jetpack" href="https://twitter.com/@dougthompson" href="https://twitter.com/@dougthompson">My Tweets</a></aside><aside id="custom_html-22" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300 Skyscraper -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-4675981680560151"
     data-ad-slot="3284684307"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="custom_html-20" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Muse Skyscraper -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-4675981680560151"
     data-ad-slot="1155348962"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>		</div>
				</div>
						</div>
			</div>
		</div>
						</div>
			</div>
		</section>
						</div>
			</div>
		</div>
						</div>
			</div>
		</section>
				<section class="elementor-element elementor-element-36e5cce elementor-section-boxed elementor-section-height-default elementor-section-height-default elementor-section elementor-top-section" data-id="36e5cce" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}">
						<div class="elementor-container elementor-column-gap-default">
				<div class="elementor-row">
				<div class="elementor-element elementor-element-b7ac455 elementor-column elementor-col-100 elementor-top-column" data-id="b7ac455" data-element_type="column">
			<div class="elementor-column-wrap  elementor-element-populated">
					<div class="elementor-widget-wrap">
				<div class="elementor-element elementor-element-f9d52c4 elementor-nav-menu--indicator-classic elementor-nav-menu--dropdown-tablet elementor-nav-menu__text-align-aside elementor-nav-menu--toggle elementor-nav-menu--burger elementor-widget elementor-widget-nav-menu" data-id="f9d52c4" data-element_type="widget" data-settings="{&quot;layout&quot;:&quot;horizontal&quot;,&quot;toggle&quot;:&quot;burger&quot;}" data-widget_type="nav-menu.default">
				<div class="elementor-widget-container">
						<nav role="navigation" class="elementor-nav-menu--main elementor-nav-menu__container elementor-nav-menu--layout-horizontal e--pointer-background e--animation-fade"><ul id="menu-1-f9d52c4" class="elementor-nav-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-44514"><a href="https://blueridgemuse.com" class="elementor-item">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52922"><a href="https://blueridgemuse.com/node/category/entertainment-2" class="elementor-item">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22448"><a href="https://blueridgemuse.com/node/category/musings" class="elementor-item">Musings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24103"><a href="https://blueridgemuse.com/node/category/news" class="elementor-item">News</a>
<ul class="sub-menu elementor-nav-menu--dropdown">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54998"><a href="https://blueridgemuse.com/node/category/coronavirus" class="elementor-sub-item">Coronavirus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24104"><a href="https://blueridgemuse.com/node/category/fubar" class="elementor-sub-item">FUBAR</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54997"><a href="https://blueridgemuse.com/node/category/news" class="elementor-sub-item">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22489"><a href="https://blueridgemuse.com/node/category/politics" class="elementor-sub-item">Politics</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22452"><a href="https://blueridgemuse.com/node/category/sports" class="elementor-item">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-22451"><a href="https://blueridgemuse.com/node/category/video" class="elementor-item">Visuals</a>
<ul class="sub-menu elementor-nav-menu--dropdown">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22450"><a href="https://blueridgemuse.com/node/category/photography" class="elementor-sub-item">Photos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24102"><a href="https://blueridgemuse.com/node/category/video" class="elementor-sub-item">Video</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25679"><a href="https://blueridgemuse.com/node/category/motorcycle-musings" class="elementor-item">Motorcycle Musings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51147"><a href="https://blueridgemuse.com/about-blue-ridge-muse-2" class="elementor-item">About</a></li>
</ul></nav>
					<div class="elementor-menu-toggle" role="button" tabindex="0" aria-label="Menu Toggle" aria-expanded="false">
			<i class="eicon-menu-bar" aria-hidden="true"></i>
			<span class="elementor-screen-only">Menu</span>
		</div>
			<nav class="elementor-nav-menu--dropdown elementor-nav-menu__container" role="navigation" aria-hidden="true"><ul id="menu-2-f9d52c4" class="elementor-nav-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-44514"><a href="https://blueridgemuse.com" class="elementor-item">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52922"><a href="https://blueridgemuse.com/node/category/entertainment-2" class="elementor-item">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22448"><a href="https://blueridgemuse.com/node/category/musings" class="elementor-item">Musings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24103"><a href="https://blueridgemuse.com/node/category/news" class="elementor-item">News</a>
<ul class="sub-menu elementor-nav-menu--dropdown">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54998"><a href="https://blueridgemuse.com/node/category/coronavirus" class="elementor-sub-item">Coronavirus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24104"><a href="https://blueridgemuse.com/node/category/fubar" class="elementor-sub-item">FUBAR</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54997"><a href="https://blueridgemuse.com/node/category/news" class="elementor-sub-item">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22489"><a href="https://blueridgemuse.com/node/category/politics" class="elementor-sub-item">Politics</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22452"><a href="https://blueridgemuse.com/node/category/sports" class="elementor-item">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-22451"><a href="https://blueridgemuse.com/node/category/video" class="elementor-item">Visuals</a>
<ul class="sub-menu elementor-nav-menu--dropdown">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22450"><a href="https://blueridgemuse.com/node/category/photography" class="elementor-sub-item">Photos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24102"><a href="https://blueridgemuse.com/node/category/video" class="elementor-sub-item">Video</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25679"><a href="https://blueridgemuse.com/node/category/motorcycle-musings" class="elementor-item">Motorcycle Musings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51147"><a href="https://blueridgemuse.com/about-blue-ridge-muse-2" class="elementor-item">About</a></li>
</ul></nav>
				</div>
				</div>
						</div>
			</div>
		</div>
						</div>
			</div>
		</section>
					</div>
		</div>
		</div>
		
	</div><!-- #content -->
</div><!-- #page -->


<div class="site-footer footer-bar-active footer-bar-align-center">
			<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope>
			<div class="inside-site-info grid-container grid-parent">
						<div class="footer-bar">
			<aside id="custom_html-21" class="widget_text widget inner-padding widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-4675981680560151"
     data-ad-slot="2311858448"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>		</div>
						<div class="copyright-bar">
					&copy; 2020 Blue Ridge Muse				</div>
			</div>
		</footer><!-- .site-info -->
		</div><!-- .site-footer -->

<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
				<span class="screen-reader-text">Scroll back to top</span>
				
			</a><script type='text/javascript'>
/* <![CDATA[ */
var hasJetBlogPlaylist = 0;
/* ]]> */
</script>
		<script type="text/javascript">
			jQuery(document).ready(function() {
				jQuery('.cat-post-item p').each(function(index, element) {
					var height = parseInt(jQuery(element).css('line-height')),
						count = jQuery('.cat-post-item p').css('-webkit-line-clamp')
					if (height == 'normal') {
						height = parseInt(jQuery(element).css('font-size')) * 1.2;
					}
					jQuery(element).css({'line-height' : height + 'px', 'max-height' : (height * count) + 'px'});
				});
			});
		</script>
	bool(false)

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/blueridgemuse.com\/node\/56153":56153};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/node/56153" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://blueridgemuse.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<link rel='stylesheet' id='ep-image-parallax-css'  href='https://blueridgemuse.com/wp-content/plugins/bdthemes-element-pack/assets/css/ep-image-parallax.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-icons-shared-0-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/fontawesome.min.css?ver=5.12.0' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-icons-fa-solid-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/solid.min.css?ver=5.12.0' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-icons-fa-brands-css'  href='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/brands.min.css?ver=5.12.0' type='text/css' media='all' />
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://blueridgemuse.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://blueridgemuse.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://blueridgemuse.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://blueridgemuse.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://blueridgemuse.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://blueridgemuse.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/dist/i18n.min.js?ver=cced130522e86c87a37cd7b8397b882c'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
;document.addEventListener("DOMContentLoaded", function(){window.wp && wp.i18n && wp.i18n.setLocaleData({"":{"domain":"gt3pg_pro","lang":"en_US"}}, "gt3pg_pro" );;window.ajaxurl = window.ajaxurl || "https://blueridgemuse.com/wp-admin/admin-ajax.php";});
/* ]]> */
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/gt3-photo-video-gallery-pro/dist/js/gutenberg/frontend.js?ver=1592333400'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/gt3-photo-video-gallery-pro/dist/js/isotope.pkgd.min.js?ver=1592333400'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gt3pg_ajax = {"url":"https:\/\/blueridgemuse.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/gt3-photo-video-gallery/dist/js/deprecated/frontend.js?ver=1592311828'></script>
<script type='text/javascript'>
/* <![CDATA[ */
;window.wp && wp.i18n && wp.i18n.setLocaleData && wp.i18n.setLocaleData({"":{"domain":"gt3pg_pro","lang":"en_US"}}, "gt3pg_pro" );window.ajaxurl = window.ajaxurl || "https://blueridgemuse.com/wp-admin/admin-ajax.php";
/* ]]> */
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/gt3-photo-video-gallery-pro/dist/js/deprecated.js?ver=1.5.2.4'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/gt3-photo-video-gallery-pro/dist/js/blueimp-gallery-indicator.js?ver=1.5.2.4'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/awesome-weather/js/awesome-weather-widget-frontend.js?ver=1.1'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/location-weather-pro/assets/js/locationWeather.js?ver=1.2.3'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/location-weather/assets/js/locationWeather.js?ver=1.1.1'></script>
<!--[if lte IE 11]>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/themes/generatepress/js/classList.min.js?ver=2.4.2'></script>
<![endif]-->
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/themes/generatepress/js/menu.min.js?ver=2.4.2'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/themes/generatepress/js/a11y.min.js?ver=2.4.2'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/themes/generatepress/js/back-to-top.min.js?ver=2.4.2'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/jetpack/_inc/build/twitter-timeline.min.js?ver=4.0.0'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor-pro/assets/lib/smartmenus/jquery.smartmenus.min.js?ver=1.0.1'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/bdthemes-element-pack/assets/vendor/js/parallax.min.js'></script>
<script async="async" type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var element_pack_ajax_login_config = {"ajaxurl":"https:\/\/blueridgemuse.com\/wp-admin\/admin-ajax.php","loadingmessage":"Sending user info, please wait..."};
var ElementPackConfig = {"ajaxurl":"https:\/\/blueridgemuse.com\/wp-admin\/admin-ajax.php","nonce":"6c2ef13167","data_table":{"language":{"lengthMenu":"Show _MENU_ Entries","info":"Showing _START_ to _END_ of _TOTAL_ entries","search":"Search :","paginate":{"previous":"Previous","next":"Next"}}},"contact_form":{"sending_msg":"Sending message please wait...","captcha_nd":"Invisible captcha not defined!","captcha_nr":"Could not get invisible captcha response!"},"mailchimp":{"subscribing":"Subscribing you please wait..."},"elements_data":{"sections":[],"columns":[],"widgets":[]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/bdthemes-element-pack/assets/js/bdt-uikit.min.js?ver=5.0.1'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=2.9.12'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/dialog/dialog.min.js?ver=4.7.6'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/waypoints/waypoints.min.js?ver=4.0.2'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/swiper/swiper.min.js?ver=5.3.6'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor/assets/lib/share-link/share-link.min.js?ver=2.9.12'></script>
<script type='text/javascript'>
var elementorFrontendConfig = {"environmentMode":{"edit":false,"wpPreview":false},"i18n":{"shareOnFacebook":"Share on Facebook","shareOnTwitter":"Share on Twitter","pinIt":"Pin it","downloadImage":"Download image"},"is_rtl":false,"breakpoints":{"xs":0,"sm":480,"md":768,"lg":1025,"xl":1440,"xxl":1600},"version":"2.9.12","urls":{"assets":"https:\/\/blueridgemuse.com\/wp-content\/plugins\/elementor\/assets\/"},"settings":{"page":[],"general":{"elementor_global_image_lightbox":"yes","elementor_lightbox_enable_counter":"yes","elementor_lightbox_enable_fullscreen":"yes","elementor_lightbox_enable_zoom":"yes","elementor_lightbox_enable_share":"yes","elementor_lightbox_title_src":"title","elementor_lightbox_description_src":"description"},"editorPreferences":[]},"post":{"id":56153,"title":"Rain%20is%20a%20soggy%20pain%20in%20the%E2%80%A6%20%E2%80%93%20Blue%20Ridge%20Muse","excerpt":"...butt. Thunderstorms are forecast for just about every day left in this already-soaked month and are expected to continue into July.","featuredImage":"https:\/\/blueridgemuse.com\/wp-content\/uploads\/2015\/05\/052815rainout-2.jpg"}};
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=2.9.12'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/bdthemes-element-pack/assets/js/element-pack-site.min.js?ver=5.0.1'></script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor-pro/assets/lib/sticky/jquery.sticky.min.js?ver=2.10.2'></script>
<script type='text/javascript'>
var ElementorProFrontendConfig = {"ajaxurl":"https:\/\/blueridgemuse.com\/wp-admin\/admin-ajax.php","nonce":"8a6800a9df","i18n":{"toc_no_headings_found":"No headings were found on this page."},"shareButtonsNetworks":{"facebook":{"title":"Facebook","has_counter":true},"twitter":{"title":"Twitter"},"google":{"title":"Google+","has_counter":true},"linkedin":{"title":"LinkedIn","has_counter":true},"pinterest":{"title":"Pinterest","has_counter":true},"reddit":{"title":"Reddit","has_counter":true},"vk":{"title":"VK","has_counter":true},"odnoklassniki":{"title":"OK","has_counter":true},"tumblr":{"title":"Tumblr"},"delicious":{"title":"Delicious"},"digg":{"title":"Digg"},"skype":{"title":"Skype"},"stumbleupon":{"title":"StumbleUpon","has_counter":true},"mix":{"title":"Mix"},"telegram":{"title":"Telegram"},"pocket":{"title":"Pocket","has_counter":true},"xing":{"title":"XING","has_counter":true},"whatsapp":{"title":"WhatsApp"},"email":{"title":"Email"},"print":{"title":"Print"}},"facebook_sdk":{"lang":"en_US","app_id":""},"lottie":{"defaultAnimationUrl":"https:\/\/blueridgemuse.com\/wp-content\/plugins\/elementor-pro\/modules\/lottie\/assets\/animations\/default.json"}};
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=2.10.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var JetBlogSettings = {"ajaxurl":"https:\/\/blueridgemuse.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/jet-blog/assets/js/jet-blog.min.js?ver=2.2.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blueridgemuse.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.6.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=12355598&postid=56153&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=d24518948f09a4d12d731a7b5676bf239c700bea#parent=https%3A%2F%2Fblueridgemuse.com%2Fnode%2F56153" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=12355598&postid=56153&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=d24518948f09a4d12d731a7b5676bf239c700bea#parent=https%3A%2F%2Fblueridgemuse.com%2Fnode%2F56153";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202025.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'12355598',post:'56153',tz:'-4',srv:'blueridgemuse.com'} ]);
	_stq.push([ 'clickTrackerInit', '12355598', '56153' ]);
</script>

</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced 

Served from: blueridgemuse.com @ 2020-06-18 11:28:19 by W3 Total Cache
-->